2018 Raspberry PI 3 Screen Freezes on Reddcoin Install during Compile Reddcoin Source Code


I have been tinkering with creating a Reddcoin Staking Wallet on my Raspberry PI 3. But when I go to run (compile) Reddcoin Source Code, my Raspberry PI freezes up and I unable to do anything without unplugging it. My Raspberry PI runs for about 20 minutes installing and then it freezes by verification of clock standing still and inability to move my mouse.I have let it sit for several days to see if I would get another outcome (slow install) with no luck. And since it freezes I cannot copy the log.

Any thoughts or any ideas on how I may be able to correct this issue in order to proceed is greatly appreciated! Thank you.

Below are the steps I have used to get me where I am currently at, based on poor (and outdated) web tutorials.

My install includes RASPBIAN STRETCH WITH DESKTOP. I chose not to do the
RASPBIAN STRETCH LITE since I am not a coder.

The below steps were a trial and error that worked for me until I got to my Big Freeze!

0 - Tutorial Utilized.

  1. Refresh OS
    sudo apt-get update
    sudo apt-get dist-upgrade

2.Enable SSH - (just so I can run code on my computer)
sudo systemctl enable ssh
sudo systemctl start ssh
sudo systemctl status ssh

  1. Screensaver - (i used this to stop my Pi from logging off so I can watch the install).
    sudo apt-get install screensaver
    Note - Select Disable

  2. Install packages
    sudo apt-get install git automake libssl-dev libboost1.50-all-dev libboost-all-dev libminiupnpc-dev eject

Note - My Log shows that Libboost1.50 does not exist so I found the below code that worked: So I installed libboost1.62


sudo apt-get install libboost1.62-*

  1. Allocating Memory with Swap (I added this up front based on other tutorials. Could this be an issue? The “0600” was added to code because my PI recommended it)
    sudo dd if=/dev/zero of=/var/swap.img bs=1024k count=1000
    sudo chmod 0600 /var/swap.img
    sudo chown root:root /var/swap.img
    sudo mkswap /var/swap.img
    sudo swapon /var/swap.img

  2. Compile BerkeleyDB (No issue with BD install)
    cd ~
    wget http://download.oracle.com/berkeley-db/db-4.8.30.NC.tar.gz
    sudo tar -xzvf db-4.8.30.NC.tar.gz
    cd db-4.8.30.NC/build_unix
    …/dist/configure --enable-cxx
    sudo make install

  3. Set environmental variables (no issues with this step)

a. Variables for compiling Reddcoin

export CPATH="/usr/local/BerkeleyDB.4.8/include"
export LIBRARY_PATH="/usr/local/BerkeleyDB.4.8/lib"

b. Variable for running Reddcoin

sudo nano /etc/ld.so.conf.d/daemon-libs.conf

c. Copy and paste


and save the config file.

d. Reload config

sudo ldconfig

  1. NEW ADD - I added this before I proceeded to step 7 (I initially had issues running ./autogen.sh and a tutorial mentioned to install this before proceeding.)

sudo apt-get install autoconf

sudo apt-get install libssl1.0-dev

  1. Download and compile Reddcoin source code (No issues with running below code. The issue is that my RB Pi freezes during installation or 20 minutes after i type “Make”.)

a. Download source code

cd ~
git clone https://github.com/joroob/reddcoin.git

b. Configure Makefile

cd reddcoin
./configure --with-gui=no --disable-tests

c. Compile reddcoind (daemon) and reddcoin-cli (client)

cd src

CONCLUSION - After this step. My Raspberry PI runs for another 20 minutes showing the install, and than it freezes by verification of the clock standing still and inability to move mouse.

Any thoughts or any ideas on how I may be able to correct this issue in order to proceed is greatly appreciated! Thank you.