Can't run Regression tests on Reddcoin

Anyone know how to run the Reddcoin regression tests?
Shouldn’t this be ready out of the box?

I can’t even post the contents on the forum, it keeps flagging my post as spam, hope it goes through this time.

Searched though forums and all over the web, but there doesn’t seem to be any reference to regtests on Reddcoin. How can I get this to run?

I’m trying to find out how to make a fake transaction, to see if I have all set up. I don’t even know if this is the right way, but any help would be appreciated.

Let’s try that again:

ln -s reddcoind bitcoind
ln -s reddcoin-cli bitcoin-cli

Still get this:

ubuntuhost:~/reddcoin/qa/rpc-tests$ ./wallet.sh ../../src
Generating test blockchain...
error: You must set rpcpassword=<password> in the configuration file:
/home/ubuntu/reddcoin/qa/rpc-tests/test.Ygn8S/node1/reddcoin.conf
If the file does not exist, create it with owner-readable-only file permissions.
: Unable to bind to 0.0.0.0:45444 on this computer. Reddcoin Core is probably already running.
: Failed to listen on any port. Use -listen=0 if you want this.
: Unable to bind to 0.0.0.0:45444 on this computer. Reddcoin Core is probably already running.
: Failed to listen on any port. Use -listen=0 if you want this.
Error: To use the "-server" option, you must set a rpcpassword in the configuration file:
/home/ubuntu/reddcoin/qa/rpc-tests/test.Ygn8S/node1/reddcoin.conf
It is recommended you use the following random password:
rpcuser=reddcoinrpc
rpcpassword=GqkRWh9PHxMRcXtQvAZeKmFhSrDBcdUXDs4jc6TZ61up
(you do not need to remember this password)
The username and password MUST NOT be the same.
If the file does not exist, create it with owner-readable-only file permissions.
It is also recommended to set alertnotify so you are notified of problems;
for example: alertnotify=echo %s | mail -s "Reddcoin Alert" adminfoo.com

error: You must set rpcpassword=<password> in the configuration file:
/home/ubuntu/reddcoin/qa/rpc-tests/test.Ygn8S/node1/reddcoin.conf
If the file does not exist, create it with owner-readable-only file permissions.
error: You must set rpcpassword=<password> in the configuration file:
/home/ubuntu/reddcoin/qa/rpc-tests/test.Ygn8S/node2/reddcoin.conf
If the file does not exist, create it with owner-readable-only file permissions.
error: You must set rpcpassword=<password> in the configuration file:
/home/ubuntu/reddcoin/qa/rpc-tests/test.Ygn8S/node3/reddcoin.conf

This is really tiring. Rebooted and it’s still the same.