How to recover coins from an old "reddcoin electrum 2.0" wallet?

Re: [With browser wallet released](Reddcoin Electrum desktop wallets are now deprecated)

Hello, All

There is an old wallet installed on my laptop, with the name like “reddcoin electrum 2.0”. I also know the magic phrase to that wallet. It does not sync anymore, showing “disconnected” all the time.
Is there a way to make it working again or move the coins to another wallet?

Thanks!
~ Alex.

alexsott Presently there is no other service to easily migrate wallets.
However, we do plan on reviving the electrum service.
I have had a server running in the past. It is a matter of getting some support going again

Gnasher Thank you for your reply!
Do I understand it right that currently there is no practical way to recover (make available) those coins? That is, unless we have the electrum server running again? If so, I think there must be many users affected by that in a very bad way.
What would it take to have the electrum server running again? What kind of support is needed?
Thanks!

Hi alexsott

The difference between electrum and core wallets is the format used to generate private keys, with Electrum being HD (keys are generated from a seed)
The electrum client/server was not too widely used (obviously you were one who did)
Let me see if I can get a lab system up which you can connect to

Hello Gnasher ! Thank you so much! Please let me know if any help is needed.

alexsott

try adding:

  • redd.ink

to your electrum network configuration

Hello Gnasher

Hmmm … it does not seem to work … could you please check the attached picture if I am configuring it right? Also tried SSL port 50002.

Thanks!

disconnected

Hi Gnasher,

Also, I would like to try re-installing the same “redd electrum desktop 2.0 wallet” on a different machine, but can’t find a distro anymore. Do you happen to have it by any chance?

Honestly, I am getting lost with all those reddcoin wallets variations:

  • redd-electrum-qt-desktop-before-2.0 (old seeds?)
  • redd-electrum-qt-desktop-2.0 (new seeds?)
  • redd-electrum-chrome-browser
  • python version of reddcoin-electrum 1.0.5 (available on pypi)
  • reddcoin-core-2.0 (this is the only one working now as it seems ??? )

could you please explain a bit of the differences? did I miss some versions and flavors?

Thank you!

Hi, Gnasher. Thank you for this post. I have a similar issue with Reddcoin Electrum wallet 2.0. It does not connect to the reddcoin network. Is there a way to copy my coin data from Electrum to the regular reddcoin wallet (without connecting to the network)? If not, please let me know whether you plan running the Electrum server soon? Thank you.

dimakor try adding redd.ink to the network config in electrum wallet.
I have my electrum test server running at that address

If demand dictates, I plan on putting a more permanent server up.

1 Like

Hi Gnasher - could you please check the config screenshot above? I tried adding redd.ink to the config and it id not work. Is there something wrong on that config screen?
Thanks!

Gnasher Hey, so the connection issue is resolved now. For the benefit of the others reading this thread - you just need to use HTTPS type of connection port 8082, host redd.ink.

Now I am having another problem though. I tried to send a bit of RDDs to another wallet and it stuck showing me “Please wait - Broadcasting” message for some 20 hours now.
All previous transactions in the “history” are “unverified”
“Network” settings show on the top “Blockchain: -1 blocks”, “Getting block headers from 1 nodes” “Server redd.ink”

What needs to be done to actually recover my RDDs? Can I send them to another wallet at all and how do I do that? Is there any other way to recover coins?

Thank you!

Anyone else can provide a suggestion? dimakor do you have the same problem with “unverified” transactions in the list and not being able to send any RDDs?

alexsott sorry for the delay in reply. For the electrum client it does need to download a header file. If it does not see that file it should sync from the available blocks on the electrum server.
This is what will be causing your delay.

Let me double check this tonight.

Gnasher thank you.
I kept it open for many days now, So far it’s still showing “synchronizing”, all transactions are still “unverified” and my rdd send attempt is still “broadcasting”.

in your previous network config screenshot you have redd.ink correctly set.
It should work for TCP and HTTP

But could you also uncheck auto-connect

Also while syncing, periodically check the Network config screen, you should see the Blockchain: value increase over time.

With Electrum there is still a sync process.
There is also a blockchain_header fil;e that can be placed to speed up the sync…
I will work on getting that updated on github for download

1 Like

Hello Gnasher,

the blockchain counter on a network config screen always shows a value of -1.

I found the local “blockchain_headers” file in AppData/Roaming/Reddcoin-Electrum. The size of that file is zero.

Thanks

alexsott
Ok, so I have been looking at what has been going on as I was having wallet issues using electrum also .
It seemed to be caused by an issue with captured transaction in the wallet file
I was able to resolve the issue by re-creating my wallet from the seed

So,
backup the wallet_file (just to be sure make a copy someplace)
Gather your wallet recovery seed ( I am assuming you have not imported any external private keys at any point)
Rename the wallet_file to something else

Start electrum wallet and create a new wallet from your backup seed

File => New/Restore

and follow the directions

you still need to sync the blockchain, but i think this will make it smoother
You can use the following blockchain_headers file to bootstrap your wallet

https://github.com/reddink/reddcoin-electrum-server/releases/tag/v0.9.0-blockchain

Gnasher - thank you! That was a great cue! I was able so send some money.

For the benefits of other users here is the procedure:

  • Delete data directory content
  • Copy blockchain headers file there
  • Start electrum, restore from code phrase
  • It won’t let open network properties at that point so close electrum and re-open
  • After re-opening modify network props and it will connect to network
  • Wait till all transactions become verified
  • Send money
  • Do not close the wallet - it will not open again (process silently dies right away)

However now I run into a new issue. When trying to send coins, it would error out with message “rejected: Transaction was rejected by network rules : (64 tx-size)”, with the following happening before that

  • transaction fee is too large (like 0.17 rdd)
  • signing transaction takes very long time

I have a feeling that wallet tries to “compound” the payment out of many-many existing fractions and overall network message becomes too big.
Can this be worked around?

Thanks!

alexsott
Ahh… Congrats and well-done.
.You have just tested the transaction malleability issue that BIP66 fixes
The electrum wallet is signing incorrectly

To explain, the currently released versions of the electrum wallet have not been fixed to resolve the BIP66 issue
Lucky for you I have been working on it, and have a wallet that does include a fix.

It is not quite ready for release…but let me see what I can do
This will take a bit of time as i need to set up a version to release

3 Likes