Incorrect or no genesis block found. Wrong datadir for Network?

Hello, Please help…I’m hoping someone can help me with this problem I’m having. I was syncing my wallet and my computer froze so I had to reboot. After rebooting I tried to open up my wallet and got this error message. “Incorrect or no genesis block found. Wrong datadir for Network” (See picture below)
Thank you!

Reddcoin%20Core%20Wallet%20Error

Dont wary. This project is dead ! My last payout was not recognized, was staking for nothing.
And its telling me payout expected every 5 days for over a month. still staking but thinking about selling at a los. Garbage. No developer addressing this problems. Give it a last chance at a next bull spike and thats it

Thanks for your insight. I figured it out and restored my wallet.

How do I fix the error “Incorrect or no genesis block found”?

The message “Incorrect or no genesis block found. Wrong datadir for network” is caused by a different blockchain with the same name.

Use the following instructions to fix this.

Note: replace “examplecoin” with the name of your coin.

  1. Close your wallet.
  2. Make a backup of the folder “%APPDATA%\examplecoin\”.
  3. Remove the folder “%APPDATA%\examplecoin\”.
  4. Start your wallet.

Hi! I am having the same issue with my wallet. I tried the above mentioned suggestion but i do not have an examplecoin in any folder.
any more ideas?

The project is not dead. Far from it. We’ve been working as unpaid volunteers since 2015.
See our primary channel at www.twitter.com/@reddcoin or www.reddit.com/r/reddcoin
First of all, if your stake was “generated but not accepted” you’ve not lost anything, that’s not how staking works. Your coin-age is only reset if you successfully stake. In addition, staking is about to change radically. Please check out our just-released upgrade v3 wallet. Looks the same, but we are activating PoSV v2.
You can read about the new wallet here https://www.reddit.com/r/reddCoin/comments/eewkek/reddcoin_rdd_core_official_release_v300rc1_posv/
and why you should upgrade here: https://medium.com/@techadept/rdd-posv-v2-with-enhanced-staking-a-simple-core-wallet-upgrade-and-a-quantum-leap-forward-for-58baf642fb1d?sk=360662ffc186857e6ed94c787ced301d

1 Like

It’s not “examplecoin”, it’s “reddcoin” if you’re trying to work on reddcoin. However, here are direct instructions on how to upgrade to the newly released v3.0 and a clean copy of blockchain data if you are having problems.

1 Like
1 Like

Hey, Matty, here you go… hope this helps.
%APPDATA%\reddcoin\