MinGW Runtime Assertion

Hi all,

Whenever I try to open my qt wallet, I receive a MinGW Runtime Assertion error:

Assertion failed!

Program: C:\Program Files (x86)\Reddcoin\reddcoin-qt.exe
File: src/checkpoints.cpp, line 285

Expression: mapBlockIndex.count(hasSyncCheckpoint)


I am not sure what to do about this. This has happened for my 1.4.0.0 and newly downloaded 1.4.1.0 wallets. Any help is appreciated! Thanks

ReddRover
Was this a new installation?
or are you trying to download the blockchain?

Gnasher It was a new installation in as much as I downloaded the 1.4.1.0 qt wallet package after having this issue with my old 1.4.0.0. It started happening with my 1.4.0.0 wallet and a fully downloaded blockchain. I can’t even get to trying to sync with the blockchain at this point because I have to abort the execution sequence upon opening of the program immediately.

Delete the folder ‘txleveldb’ in your Reddcoin data-folder, which is most likely: %AppData%\Roaming\Reddcoin

lionzeye That worked good sir. Could you give me a layman’s reason as to why it worked though?

Thank you for the help. You too Gnasher .

Cheers!

ReddRover
Sorry i didnt get to reply further to you,
I just finished a 24hr shift at work

Thanks lionzeye for picking it up and resolving.

1 Like