No Block Source Available with 3.10.2

My wallet has been working fine for the last few months, until around a week ago when it stopped synching. I backed up the wallet.dat file, grabbed the latest version of the core wallet (3.10.2), restored the dat file and launched it.

I can see my coins and old transactions, and there are 8 connections to the network, but it says, ‘No Block Source Available’. Is it just catching up or is there another problem?

Sorry for the newbie question. Any responses will be welcome.

Could you check if you are connected to v2 or v3 peers?

Go to Help (menu) -> Debug window -> Peers.
If you are connected to version lower than v3 (so, v1 and v2), right click on those peers and disconnect from those peers.
Try to connect to only v3 peers.

Let me know if this helps.

1 Like

I had 2 connections to 2.x peers and have now disconnected them, thanks for the tip! The Problem remains, but I will persevere with it for now.

Your blockchain needs to be synced fully before you can use Reddcoin Core properly (staking, making transactions etc).

Could you please try these steps? https://wiki.yavuzselim.nl/tech/tutorials/reddcoin-cant-connect-to-the-network-blockchain-not-syncing-try-these-steps-to-get-it-working/.
It’s old, but still might work.

If this also doesn’t work, I’ll contact the Reddcoin developers to ask for help/what to do.

1 Like

Thanks, it’s still not working… and same problem.

Solve the issue by manually adding nodes using reddcoin.conf .

What nodes should I add in here? Could be it.

Ah, I see that the GitHub link is down (changed my username).

You can use one of the mirrors, for example: https://pastebin.com/iX3A1aSi.

1 Like

I found it and added the file (it didnt exist), with the contents. It has made no difference.

image

You have put the file in the wrong/incorrect folder.

The file should be placed in the same location as the blockchain files. The end result should look like this: https://wiki.yavuzselim.nl/wp-content/uploads/2019/01/ReddcoinConnectionIssues_005.png. In your screenshot, it’s placed in the installation folder of Reddcoin.

The default folders for Windows is (you can copy/paste the following into the address bar in File Explorer):
%APPDATA%/Reddcoin

 

  • If you can’t find your Reddcoin data folder, try this method:
    • Start Reddcoin Core.
       
    • Open ‘Debug window’, via ‘Help’ -> ‘Debug window’.
      Screenshot
       
    • The ‘Debug window’ appears on the screen, showing the ‘Information’ tab. Click on the ‘Open’ button at the bottom to open the ‘Debug log file’.
      Screenshot
       
    • The debug log file will be opened. Search for the following in the file (CTRL + F) to see your data folder: Using data directory.
      Screenshot
       
    • In this example, the data folder is “C:\Reddcoin”.

 

All explained in the tutorial I linked to earlier. Try placing the reddcoin.confin the folder as explained above.

1 Like

I’ll also ask the developers, it might result in an easier/better solution. I will let you know when I know more.

I have asked the devs about.

Disregard my previous suggestion, and please try this:

  • Make sure Reddcoin Core is not running. If it is, exit/close Reddcoin Core.

  • Open your Reddcoin data folder. Explained in the post above.

  • In that folder, there is a file named peers.dat. Rename that file, for example to old_peers.dat.

  • Start Reddcoin Core. It should start with a clean list of hosts to connect to, and this should solve your issue.

Let me know if this solves your issue.

@slobberchops
What is the status of your issue?

1 Like

Hello…no change, I have tried all your suggestions and still can’t get to my coins.

Can you show me a screenshot of your Reddcoin data folder (where peers.dat can be found)?

1 Like

I don’t have a peers.dat file. There was a suggestion from somewhere to delete it and that it would be re-created but that has not happened.

image

image

I dont run the wallet.dat from the %APPDATA% folder. That is the only file in the data folder and it’s clearly reading from it, as my stake can be seen.

Peers are being picked up on…

image

The debug file looks like this…

The screenshot of the folder you posted looks to be same as before. As mentioned in this post, it’s the wrong folder. So, anything you do doesn’t affect Reddcoin Core, as it’s not put/done in the right folder.

There are 2 relevant folders:

  • The installation folder: this folders holds all the software wallet files of Reddcoin Core. This is the folder that has reddcoin-qt.exe, in your case this folder is D:\Program Files\Reddcoin3.10.2.

    Everything is OK in this folder, nothing needs to be done here.

 

  • The data folder: this folder holds all the blockchain files, your wallet file (wallet.dat), as well as some other files as peers.dat.
     
    As mentioned in the previous post, please use the debug log file to find this folder. The inf you need starts from “If you can’t find your Reddcoin data folder, try this method:”.
     
    The Reddcoin data folder looks like this: screenshot.

 
 

  • So, after finding the Reddcoin data folder, there should be a peers.dat in it…
  • Make sure Reddcoin Core is not running.
  • Rename the peers.datold_peers.dat.
  • Run Reddcoin Core.

 

Let me know what the result is…

Hm, after seeing the debug file…

If the previous step doesn’t work, I think the solution would be to do a reset of the blockchain (removing current blockchain files and syncing/downloading the blockchain fully again).

  • Try the peers.dat solution above.

If that doesn’t work, do this:

  • Make sure Reddcoin Core is not running, exit/close if it is.

  • In your Reddcoin data folder (explained above), rename these 2 folders:

    • blocksold_blocks
    • chainstateold_chainstate
  • Start Reddcoin Core.

  • It should be sycing the blockchain from zero… Let it sync fully.

 

Let me know how this one goes.

I have seen this issue occur with a few other users in the last few days.

Have tried a few things, but nothing works. I am currently in touch with the developers; if I have a solution, I’ll share it here as well.

@slobberchops

An issue has been fixed, syncing should now work again. Please test.

Hi,

  • blocksold_blocks
  • chainstateold_chainstate

None of these folders exist, nothing has changed. I dont have a peers.dat either.

I have asked if syncing works now for you, but didn’t receive an answer…

Many users reported having syncing issues (just like you). I have contacted the developers about it.
Yesterday, the developers fixed an issue which resolved issues with syncing. So, blockchain syncing should work again. And, a new version has also been released.

So, please: