reddcoin paperwallet , cannot import to reddcoin client :( keeps saying Error: Error parsing JSON:rescan) and Invalid private key encoding

cannot import to reddcoin client :frowning: keeps saying Error: Error parsing JSON:rescan) and Invalid privTE KEY encoding

Please show us the command you are using to import your private key but DON’T show the key itself.
Maybe there is something wrong.
Make sure your key has only numbers and letters.

hi ballor

thanks for the quick reply :slight_smile:

i guess first of all my wallet is out of sync (just downloaded it recently)

in the debug window i am typing

importprivkey “privatekey” (“label” rescan)

ive also tried

importprivkey “privatekey”

any ideas mate?

Okay, I’m getting the same error with “rescan” within the command.
That’s what i’ve expected.
Does your private key look like this one?

V6ZmzHnEr8YqadBrpEWmhBnUMY93LNj7wUd8KEGQL6QCmZgAFtbG

I’ve tested this command for import.

importprivkey V6ZmzHnEr8YqadBrpEWmhBnUMY93LNj7wUd8KEGQL6QCmZgAFtbG test

After hitting enter my wallet freezes for about 10 minutes but then it gets responsive again and the key is successful imported.
Could you test it again with your key?

thanks for your help ballor!!

my private key looks like that however my key has 6 extra characters

its worth noting i used mywalletgenerator and created a paper wallet.

the private key is the key from that paper wallet.

i tried importing ur test key and it worked fine

any ideas??

ive double checked my key and it is exactly the same as my paper wallet key

Oh dear what are you guys doing all this time?!
Your private key was converted to WIF (Wallet Import Format)
It looks like Reddcoin core wallet can’t handle that.
These Idiots doing this without providing a simple solution to convert it back.
Strange is the fact, that it should have less characters…

I’ve found a converter on this site.
I don’t know how trustworthy it is so it’s only a desperate solution.
If you’re trying this i advise you to send your Reddcoin immediately to another address!
It would be a good idea to load up this page and cut your internet connection before you are entering your private key.
After that close the page before connecting internet again.

hi i have a reddcoin wallet fully synced … i also have a paper wallet private key … when i input importprivkey nothing happens but a time stamp … when i tried the test key above it worked and started rescaning , but i tried it again and nothing happens again but the timestamp … what do i need to know about importing my paper wallet priv key

downloaded Coinomi app and “Sweep Wallet” accepted paper wallet key

hi ballor i’ve tried converting it however it says “Private key is not on curve”

ive also tried importing it into coinomi on android.

when i go to sweep paper walle and insert my private key it asks for a password.

i then proceed to type my password for the coinomi app and it says incorrect password…

djty05
As I don’t trust any third party software/apps I have no clue about coinomi.
But on the process of creating a paper wallet on mypaperwallet there was an option to specify a password on that.
So I assume you’ve entered a password for your paperwallet itself.
If you remember that, try to enter it in coinomi.