[Solved] Another one who sent coins that never arrived

Hi there!

I inherited the reddcoin wallet from my late husband.
It’s out of date (version 5.2.1) and on a Mac.

I tried sending some coins to Bittrex, but the Transaction ID (even without the -000) doesn’t show up on the blockchain and never arrived at my Rdd account at Bittrex. (The address at Bittrex is valid, I checked)

Following the transaction:

Status: 57535 confirmations
Date: 06.12.20 14:10
To: Reddcoin Rwg2BwFtYWe1QToYF23rJFz8hn3eWwq6p7
Debit: -1 000 000.00 RDD
Transaction fee: -2.00 RDD
Net amount: -1 000 002.00 RDD
Transaction ID: 29405eaa8b1f66f7b87b8ef5e5159325f36c9419e2c7a4d9c8fb4fe651760af1-000

I’ve tried updating my Rdd wallet and followed a protocol for Mac, but somehow there was no Reddcoin folder in the ‘Application Support’ folder of the ‘hidden’ Library folder.

Can anybody help me out?

Hi there.

Summary of the issue:

  • Reddcoin has upgraded its staking (a few months ago). Older version of Reddcoin Core do not function fully (sending and staking), you need to upgrade to the most recent version.

The fix:

  • Undo/remove the transaction (RDDs will be put back in wallet).
  • Update to version 3.10.3.
  • Make a new transaction, with correct transaction fees.

Solution:

  • I can write out the instructions and you can follow them. This is the slower option.

  • If you agree and feel comfortable with it, I can fix the issue for you. By using TeamViewer, I can see your screen and do the steps for you. This is the quicker option.

Let me know what you prefer.

Dear Yavuz_selim,

Thank you so much for your quick reply!

If you don’t mind - and if it’s not too much work for you - I would prefer to follow your written instructions, because in this way I can keep them and learn more about how everything works.

First, you need to undo/remove the transaction.

I assume you have put the Reddcoin-Qt application in your Applications folder.

  • Open Reddcoin Core and make a backup.

    • File (menu) → Backup wallet.
    • Do not skip this step.
  • After making a backup, exit/close Reddcoin Core.

  • Open the Terminal app.

  • Enter these commands in Terminal:

    • cd /Applications
    • Reddcoin-Qt.app/Contents/MacOS/Reddcoin-Qt --zapwallettxes=1
  • Reddcoin Core will start, let it load. It can take a while.

  • After Reddcoin Core is fully loaded, check your Transactions list and your balance. The transaction should have been removed, and the RDDs are placed back in your balance.

Let me know how it goes. If all went OK, we will continue with the steps next.

I did everything you told me to, thank you for your help, by the way, but the balance did not change. It’s still missing the two transactions.

My mistake. I am helping a few people at the same time at the moment, I mixed up two issues. In your case, the transactions were confirmed, I thought they weren’t.

You have followed the steps, good.

  • You now have a backup.
  • All the incorrect transactions are removed.

We now can now can continue with the next step: deleting existing blockchain data.

 

Open the Finder app, and, in the top menu, select Go > Go to Folder.
Enter this:
~/Library/Application Support/Reddcoin

 

After you do this, you should be in the Reddcoin data folder.
You should see folders like blocks and chainstate, and files like peers.dat.
Do you see them?

No, that’s the thing. There is no Reddcoin folder in the Application Support.

The default location is in Application Support.
A different location might have been selected when Reddcoin Core was installed.

(Screenshots below are made on Windows, but they can still help you.)
 

  • Start Reddcoin Core.
  • Open ‘Debug window’, via ‘Help’ -> ‘Debug window’.
    Screenshot
  • The ‘Debug window’ appears on the screen, showing the ‘Information’ tab. Click on the ‘Open’ button at the bottom to open the ‘Debug log file’.
    Screenshot

  • The debug log file will be opened. Search for the following in the file (CTRL + F) to see your data folder: Using data directory .
    Screenshot

In this example, the data folder is “C:\Reddcoin”.

What do you see as your ‘using data directory’?

Okay, so, as expected, a different location is selected when Reddcoin Core was first used.

As you can see, there is a ‘default data directory’ (not existing in your case), which is superseded by the ‘using data directory’.

Open the Finder app, and, in the top menu, select Go > Go to Folder.
Enter this:
/Volumes/Aspire

What do you see? Can you make a screenshot?

Sorry for taking such a long time to reply. I had an appointment.

All right. We have found the files we need.

Now, normally I would say that you need to delete folders, but as you don’t know the contents, I am letting you rename them (instead of deleting).

Exit/close Reddcoin Core, make sure it’s not running.

Rename the following folders:

  • blocksold_blocks
  • chainstateold_chainstate

Rename the following files:

  • peers.datold_peers.dat

After these steps, download the following files:

Let me know when you have downloaded these files.

Done!!

It did take a while :slight_smile:

  • Move the blockchain-Nov-26-2020.zip file to the folder where you previously renamed the folders/files (/Volumes/Aspire).

  • Double click it. The zip file will be extracted. You should now see the following folders:

    • old_blocks and old_chainstate that you already had.
    • blocks and chainstate (new, added after the extraction).

Let me know if you see those 2 new folders.


  • Now, open your Applications folder. The Reddcoin Core app - named ReddcoinQt.app - should be in there.

  • Rename the Reddcoin-Qt.appold-Reddcoin-qt.app.

  • Open the reddcoin-3.10.3-osx-signed.dmg file you have downloaded.

  • You should see a Reddcoin-Qt.app.

  • Move this file to your Applications.

  • Run Reddcoin Core (open the Reddcoin-Qt.app`).

  • Blockchain will be synced… Let it sync, wait until it’s finished.

  • Check your Transactions, do you see the transaction (1 million RDD) to Bittrex? (You shouldn’t).

  • Check your balance: it should be old balance + the transaction of 1 million. Is this your balance?

Let me know the results.

If this all works out, we will need to do the last step: make a new transaction with the correct fee.

Yay!!! It worked!! :slight_smile: :slight_smile: :slight_smile:

It’s still syncing, but I can already see the balance!

Now, may we practice sending coins by sending some to you, for your invaluable help?

Because without you, I wouldn’t have been able to retrieve my coins in a million years!

I am glad to hear that it worked. :).

Please wait with sending any RDD until the blockchain is fully synced. The synchronizing with network disappears when the blockchain is fully synced, and the (out of sync) (in red) in Overview also disappears.

After the blockchain is fully synced, you can start using Reddcoin Core.

 

When making transaction, please use these settings to make sure your transaction has the correct transaction fees (so the transaction will get confirmed quickly)…

When making a new transaction, do this (in the Send window):

  • Enter the receiving address and the amount.
  • Click on ‘Choose…’ at the bottom.
  • Select ‘Custom’.
  • Select ‘total at least’.
  • Set value of ‘total at least’: 1 RDD.
  • Uncheck ‘Send as zero-fee transaction’.
  • Make the transaction.

 

I appreciate your gesture of sending me Reddcoins! Thanks.
You can practice by sending them to this address:
RdyJ2w5g2YBFff3JQXTmP44gXeCQQ1QitQ

And some extra info:

  • Reddcoin Core marks a transation as confirmed when the transaction has 6 confirmations.
  • Bittrex marks a transaction as confirmed when the transaction has 20 confirmations.
  • A confirmation takes around 1 minute.
  • It will take at least 20 minutes before your RDDs will appear on your Bittrex balance. However, you should already see them appear under ‘Pending deposits’.

Good to know. Thanks!

I’ve just sent you 10 000 Rdd and hope they arrive safely in your wallet!

The amount has been taken from the total, but the recent transactions window doesn’t show any sent transaction.

Could you confirm the receipt of the coins?

And how do I restart staking?