[Solved] Wallet balance zero after send transaction

Yavuz_Selim navigate me here to post this topic. Reddit history:

General problem description:
I am running linux (Ubuntu 20.04.2 LTS) with wallet v3.10.3.
I had around 496,000 RDD, then I have send 1000 RDD (Trandaction Id: b567a8a8278ec6276ea7e227aa01dcb090993421f56f63857bc1223a512eb8a0) and I am expecting to see 495,000 RDD. But I see zero in all balance fields. On one receiving address is missing 495,000 RDD.

I have downloaded this file: https://download.reddcoin.com/bin/bootstrap/blockchain-Nov-26-2020.zip.
And I see .reddcoin directory.

What can I do next?

The .reddcoin directory is your Reddcoin data folder.
It contains your blockchain data and wallet file.


  • Make a backup of your wallet first.
    Reddcoin Core → File (menu) → Backup wallet

  • Close/exit Reddcoin Core, make sure it’s not running.

  • In your Reddcoin data folder, delete the following folders:

    • blocks
    • chainstate
  • Delete the following file:

    • peers.dat


The blockchain-Nov-26-2020.zip you downloaded earlier, contains blocks and chainstate folders.
So, unzip this file and move the contents (the 2 folders), to your Reddcoin data directory - where you earlier deleted the folders.


Start Reddcoin Core. It will need to sync 11 weeks of blockchain data.
To speed up the syncing of weeks of syncing, you can do the following:

  • In Reddcoin Core, go to: → Help (menu) → Debug window → Peers.
  • Make the Peers window wider.
  • You are interested in the column ‘User Agent’. Make the column wider to see its contents.
    • User Agent is “Reddcoin:3” = OK.
    • User Agent is “Reddcoin:2” = not OK. Right click on it and ban it for a year.
    • Do these steps for every Reddcoin:2 user agent that you see.


When your wallet is fully synced, do you see the correct balance in your wallet?

Yes, now is there correct balance. Thanks a lot.
It was my first experience with send transaction. Is it necessary to do it every time, right?

Interesting event have happen. I have tried to send the rest of money to the bittrex and aprox 20 minutes was transaction unconfirmed and then this two transactions appear in history:

Status: conflicted
Date: 29 Jan 2021 17:59
To: Rfdf6CfxmrKQ34pMeYbsbgSbjE84JyjwzU
Debit: -495 014.24683192 RDD
Transaction fee: -0.00099999 RDD
Net amount: -495 014.24783191 RDD
Transaction ID: 30f5f7bec2f3e39c9259004f8a8aead640cf95566bbdafe26cea73dc27f33eeb-000

Status: 0/unconfirmed
Date: 29 Jan 2021 17:59
To: Rfdf6CfxmrKQ34pMeYbsbgSbjE84JyjwzU
Debit: -495 014.23000000 RDD
Net amount: -495 014.23000000 RDD
Transaction ID: 03d911d13da40cede6672ce2fc937d73f0dc5563ed9d41732d59483665b382a1-000

What is interesting that they have old date.
What does it mean? How is it possible?

Do you know how to use Terminal?

You need to start reddcoin-qt with the -zapwallettxes=1 option. This will remove the conflicted transactions.


  • Open Terminal.
  • cd to the directory where you have put reddcoin-qt
  • Run reddcoin-qt with the -zapwallettxes=1 option.
    • ./reddcoin-qt -zapwallettxes=1
  • Reddcoin Core should start, wait until it’s loaded. Once loaded, check your balance and the transactions list.


Can you do these steps?

Yeah, terminal is natural environment for me.

Thanks a lot, transaction was finally received by oposite site.

But still I do not understand how is it possible that I have got these troubles. ??

Your issue is solved, correct? Glad to hear that.

It’s hard to say what caused the issue on your side, as I don’t know which versions you exactly used or when you updated Reddcoin Core etc.

To keep it simple:
In July 2020, Reddcoin Core upgraded its staking mechanism.
The result was that old version of Reddcoin Core (v1.x, v2.x) were on the old chain.
And the new/current version (v3.x) is on the current/new chain.

It could be possible that your Reddcoin Core was still on the old chain, leading to conflict.


But your blockchain data is correct now, so you should not have any conflicted transactions anymore.