Trouble using new Wallet

Dear RDD community,

First i want to let you guys know i destroyed 2 computer mouses out of anger because this wallet is really grinding my gear.

In the past i had success installing the RDD wallet on my mac osx. But after a while for no reason it would not start up anymore and would give me some kind of error. only solution was deleting the wallet, install it again and let it resinc again for weeks.

Now after a few months i tried it again with the new wallet version. but with no success. i tried using the files from cryptochainer but is just does not work. This wallet is making me absolutely f*cking insane.

Can someone please help me with this evil software.

No need to delete the wallet software. What version of OSX are you using?

You can just recheck the blocks you’ve already downloaded though instead of having to redownload everything again.

Even with the bootstrap files: you still will have some sync time. However soon, we’ll have a lightweight wallet. Not sure on the details yet but I also feel your frustration.

I have downloaded the file from cryptochain but there is something wrong with the file i think. I have tried this method on windows as well as mac and they both dont work. Following message pops up: a block in the file has been damaged or something. Therefor is has te reindex

Hi,
I also have the same problem with my new wallet… I have updated my wallet a few weeks ago. After putting somecoins in it for staking (saying that the wallet will stake every 2days) it suddenly shutdown and now it says out of sync for 3yrs and 40months… The wallet is open for almost 24hrs now but it still says 3yrs and 40months out of sync…what should i do? Tia…

How am i going to do that? This how my wallet looks like
https://ibb.co/cDNydn
https://ibb.co/huYJB7
Tia…