Updated Wallet version and changed password - I get the error passphrase is incorrect

As I was using an older version of wallet Qt on my mac ( I decided to update to the newer one (

I made a backup of wallet.dat and then update my wallet. After that I also changed my passphrase. I did a minor change from a password like “hello” to “hello!”. Just adding a symbol for extra security.

Few minutes later I went on to unlock my wallet for staking purposes. Now I am getting this error: “The passphrase entered for the wallet decryption was incorrect”. I then entered the old password again and I got the same error. Tried different passwords just in case but still having this error. Note that I am 100% sure the password I enter is correct.

Any clue what might gone wrong? Also I have the old wallet.dat file. I can recover my old wallet right? If so what is the procedure?

Thanks in advance,

I was able to get access on my wallet by using the backup wallet.dat file. I will try to change my password again and see if it succeeds this time. I will update you.


Before you do this, Have you backed up unencrypted?

If you have backed up, then rename wallet.dat from the .reddcoin (If you use *nix, the location should be /home/[user]/.reddcoin) to wallet_.dat, then copy your old one to figure it.

1 Like

thanks for posting.
I have not backed up unencrypted version of wallet.dat but the encrypted version I have has the old password that I know of. Isn’t that ok?

I couldn’t find the location you mentioned (even through the terminal). What other locations should I look for?

Thanks in advance!


You can try again. It is supposed the encryption function never be changed or there will be bigger problem.

I restarted the client and tried again but still getting the same error.


I have got the same problem. I have been minting RDD dor 4 months and so far password had worked but since yesterday I cannot unlock my Reddcoin Wallet. Since yesterday I tried different solutions and nothing works so far. Any more advice? :slight_smile: