Wallet constantly crashes/freezes!

I’ve been involved with crypto for over three years and I’m not a newb. I mined a lot of Reddcoin when it was first created years ago, and I really like the goals of the project. But I’ve never had more trouble with a wallet in my life! I’m using a Windows 8.1 PC with an Intel i3 CPU, and 8 GB of ram, so more than capable. I downloaded the latest wallet 2.0.0.0 and installed it, and deleted everything but my wallet.dat in the appdata\roaming\Reddcoin directory and downloaded the fast start pack like suggested in other posts here. Unzipped the file with 7-zip and placed it in the appdata\roaming\Reddcoin directory and ran the wallet. Starts to load from disk and after say 30 minutes it freezes with zero CPU/disk/network activity in the task manager. Restart it, same issue. Gave up on fast start pack. Try to sync from network, so delete everything but my wallet.dat and start over. Over 3 years to sync. 8 connections, but very slow. Wallet freezes as previously described, or crashes. But it does make some progress each time, so I keep checking on it while I watch TV and kill it when it freezes/crashes and restart. This takes days! Finally get to about 1 year left of sync and get this error message after it loads the blockchain:


Runaway exception

A fatal error occurred. Reddcoin can no longer continue safely and will quit.

EXCEPTION: St13runtime_error
CWalletDB::ListAccountCreditDebit() : cannot create DB cursor
C:\Users\name\Coin\Wallets\ReddCoin [RDD]\reddcoin-qt.exe in Runaway exception


OK

Happens every time I launch the wallet now. WTH?! I finally deleted the latest two files in the blocks folder to see if I could get past the error, but then it tells me the blockchain is corrupt so I select to rebuild the database, and now I’m back to 3 years to sync. Wallet does the same thing in that it loads some data from disk and then freezes/crashes. I’m willing to cooperate with whatever needs to get done to get synced, but this is just unbelievable. The state of the wallet is really, really bad, at least if you need to sync a significant amount of the blockchain. This doesn’t bode well.

quadraq thanks for reaching out.
the new wallet is quite cpu intensive and if you are syncing, the wallet goes through quite a few operations and it looks like it has frozen.
Ideally, just let it do its thing, and it will eventually catch up the blockchain.

So, I suggest to speed things up, that you use the bootstrap method, and allow about 24hrs for it to catch up

We do have in the works to make several improvements on perfomance

Can someone please advise how I use the bootstrap file on a macbook, this wallet is crazy complicated to get to work…isn’t this going to be a major problem for having any new users take up the coin?

I’m keen to support it but having massive issues trying to get the wallet to load???

Any help would be much appreciated, thanks

LHTC once you’ve got the bootstrap.dat file, navigate to the Reddcoin wallet data directory, which should be /Users//Library/Application Support/reddcoin/ and just drop it in there before (re)starting your Reddcoin wallet.

Gnasher Thanks for trying to help, but I did do exactly as you suggested and the wallet always freezes. And I’m NOT talking about Windows reporting it as not responding. I know when a program is very busy that can happen, and that’s fine. When I first did this I let it run for 24 hours as you suggest and when it didn’t finish I pulled up the Task Manager to check on it. That’s when I noticed that there wasn’t ANY CPU activity, or ANY disk activity, or ANY network activity. I watched it for a while to see if that would change and it did not, so I killed the process. When I restarted I saw that it had only processed a few weeks worth of transactions. So I let it run again this time keeping the Task Manager open to see what it was doing. At first it pegs one of the CPU cores, and there’s disk activity as well so I know it’s working. But after 30 minutes to an hour that stops and it shows ZERO CPU/disk/network activity and it stays that way no matter how long I wait. When I kill it and open it again I see it made a little more progress but not a lot. So that progress apparently occurrs during all the CPU activity, but once that stops it’s just dead. Alternatively I do get crashes sometimes instead of the “frozen” wallet. This is what it looks like in the Task Manager and as I said it stays that way indefinitely. So there’s definitely a bug of some sort in the wallet involving processing the blocks. I’ve tried both the 32-bit and 64-bit version and they both have the same problem. alt text

So this is what it looks like this in the task manager when I first launch the wallet (after the split screen):
alt text

After a while (say 20-40 minutes) it looks like this in the task manager and it stays this way no matter how long I leave it:
alt text

So after I right click it and select End Task and then reopen the wallet this process starts over. But I’ve noticed something interesting. After the splash screen the wallet reports on how many blocks remain to process and every time I’ve done this it’s moved forward in time by 4 weeks. So for example it report 2 years 16 weeks left to process - runs then freezes, relaunch the wallet and then it will report 2 years 12 weeks left to process. Repeat and it reports 2 years 8 weeks left to process. So the “freeze” seems to occur after it processes 4 weeks worth of blockchain data. Is one of the developers around? This is the sort of thing that might help to find and fix the problem.

quadraq thanks for the very detailed report. Nice to see quality information about an issue when it occurs…

I would be very interested to see the debug log at the same time.

Now one thing to bear in mind that is different to other wallets, is we enable tx-indexing as a requirement. This will have an overhead compared to other wallets and it is used to speed up the coin selection during staking.

We are looking to include header-first download into the next wallet version to speed the blockchain download

UPDATE: I tried this on another PC and I had exactly the same issues as described already. So I decided to take a different approach. I renamed the Reddcoin folder to “Reddcoin_old” and launched the wallet again. It prompted me for the location for the data folder and I accepted the default location. Then I let it sync with the network using the empty default wallet. And it synced! It took about 36 hours so it wasn’t exactly fast, but I was able to get it fully synced so I was excited. I then closed the wallet and copied over my wallet.dat folder, and reopened the wallet. Splash screen comes up and it starts re-scanning, but when it hit 57% it crashed with the following error:

Runaway exception

A fatal error occurred. Reddcoin can no longer continue safely and will quit.

EXCEPTION: St13runtime_error
CWalletDB::ListAccountCreditDebit() : cannot create DB cursor
C:\Program Files (x86)\Reddcoin\reddcoin-qt.exe in Runaway exception

This is the same error as I reported in my opening post. Interesting. After closing the wallet I tried running it again, and it started the re-scan from the beginning and it crashed at 57% again. Tried a third time with identical results. So it’s consistent.

When I tried synchronizing with the network originally I had my wallet.dat file in the Reddcoin folder and it did show all my coins properly, and since all the transactions go back to March, 2015 and earlier, they actually show as available pretty quickly when synchronizing, but I can’t get the wallet to synchronize fully in that scenario as I described in the opening post.

Clearly I need the help of a wallet developer at this point to be able to resolve this. The good news is that if I send you my wallet.dat file it should be pretty simple to recreate the error and see what’s happening in the debugger. (I’m a programmer of 17 years and I know the value of a consistent test case, when it comes to finding and fixing a bug.) But of course I don’t want to send it to anyone but the wallet developer. Can the developer PLEASE contact me and look into this? I spent a lot of time and effort mining this coin back in the day, and I really want to stake my coins and support the network, but I’m stuck at this point. Please help! Gnasher

Hi there,

I was experiencing the exact same problem and have been able to successfully fix it by adding the command line option -salvagewallet.

Make sure to backup your wallet.dat first.

In Windows i did this:

Create a shortcut to the redd qt wallet. Right click - select properties. On the shortcut tab under target add -salvagewallet at the end. Then start the wallet via the shortcut.

After doing so, the wallet synced pretty fast and wasn’t freezing anymore. Pretty sure this might help you too. :slight_smile:

(After complete sync you should delete the shortcut or delete the -salvagewallet command from it)

Нормально грузится, осталось 5 недель синхронизировать. Грузился недолго. Сделайте ярлык на рабочий стол и открывайте кошелёк через ярлык.

simplyredd Thank you!! That finally seemed to do the trick. I sent you a tip for your help. I really appreciate it. :slight_smile:

quadraq simplyredd answer is the correct one, i have noticed a few times now where there is corruption in the wallet.dat will prevent the sync.

In this case, I suggest to you to to make a clean backup of that new wallet.dat

And welcome to Reddcoin :slight_smile: