Wallet empty after multiple crashes

By the way, backing up your wallet.dat (method 1) is enough to recover everything on that wallet. But, in case your backup(s) gets corrupted (which can happen), you can use the private keys (method 2).

So, method 1 (backup wallet.dat) is absolutely mandatory. Backing up the private keys (method 2) is highly recommended.

Also, always backup after creating new addresses. And try to backup regularly.

I put the single RDD address I have into the Reddcoin blockchain explorer you gave me. It showed this:

image
I’m not sure what that indicates. The final balance of 586K is close to the 583K I had but the 4.94M received and the 4.88M sent are unexplained. The 583K I recorded on 4/3 could have grown to 586K by the time it crashed but the other received and sent are a mystery.
I installed Everything and got this:
image

Can you post a screenshot of the Debug window?

Via the menu Help -> Debug window. It should show the Information tab.

I assume your blockchain isn’t fully synced. Your wallet should show 586K.

By the way, this is also the address that you have as a recieving/request address in your wallet, correct?

Has to do with staking. You’ll have transactions like the ones you see when you’re staking.

Thanks for sticking with me. Here’s the debug window:


And here’s the wallet itself. I don’t believe it is doing any syncing. How do I tell if it is?

Transaction window just shows the original deposit:

The address I have used is the only one I have.

Try starting Reddcoin Core with the -rescan option/argument.

I think the easiest option is:

  • Open the folder of where reddcoin-qt.exe is in.
  • Right click on the .exe file and select ‘create shortcut’.
  • There should be a new file on the folder, the shortcut. Right click on the shortcut and select ‘Properties’.
  • In the properties screen, there is a ‘Target’ field. It should point to the location of the reddcoin-qt. The value is between " " -> add a space and -rescan behind it. So it will look something like this: "C:\...\...\reddcoin-qt.exe" -rescan
  • Open thr shortcut by double clicking it.
  • Reddcoin Core will be started, it will rescan the blockchain for relevant transactions. Wait until it fully loads.

Let me know how this goes…

Once again I followed your clear instructions. Here is the result:

You saved my wallet and recovered everything. I backed up the wallet immediately.
Can I send you some RDD as a thank you?

  • Ed

I have to say that it was really easy to help you, as you were willing to follow instructions and even made efforts to provide the requested screenshots. So, we both did a good job!

I am really glad that you have recovered all your Reddcoins. Don’t forget to backup regularly, :).

Good luck with staking! You will earn a lot more soon, when PoSV v2 is activated, so keep on staking, hehe.

You don’t have to send me anything, but a tip is always appreciated of course. My address:
RcoDw86oYBRf4sUzy3z7b4dbFU6S4ccWv3

Thanks!

And just to make sure:

You can start Reddcoin Core the regular way, as you always started. You don’t need the shortcut (with -rescan) any more, that was for one time only, to make sure your balance was displayed correctly.

Thank you for the tip, I appreciate it. :).

Thanks for your information, it means that I have been wrong using RDD wallet backups, because my way is when RDD wallet is offline,% appdata%, roaming then open RDD wallet and copy wallet.dat and save it.

I would recommend the backup method using Reddcoin Core itself. So, via File -> Backup wallet….

By doing so, you are sure you have the correct backup file.

Hello again. I’m in trouble, but this time it should be easier.
I updated my wallet to 3.10. First I backed up the wallet. I had the program put the files in a new Reddcoin directory. I started the application and it registered all the RDD it was supposed to. I wanted to delete the old directory but the system told me that it couldn’t do that because a file was open in another application. So I closed the wallet. I deleted the old directory. When I opened up RDD again, it told me it had no RDD, the wallet was syncing, and it was 6 years and 23 weeks behind.

I went to our previous conversations and tried starting Reddcoin Core with the –rescan option/argument. That did not work. It still said no RDD, wallet is syncing and 6years and 23 weeks behind.

Since I have a backup, how do I use it? There is no obvious way from the readily available dropdown menus.

Please check which version of Reddcoin Core you are using. You can find this info in the debug window (Help -> Debug window). If you using v3.10.0, please update to the latest v3.10.1. This version has bugfixes and is heavily recommended. You can download it from here: https://download.reddcoin.com/bin/reddcoin-core-3.10.1/. If you need help with this, let me know.

 


 

Now onto your issue…

There are two directories that are relevant for Reddcoin:

  • The installation folder. This folder holds the Reddcoin Core program, the wallet software. When updating/upgrading the wallet software, the files in this folder are updated/upgraded.

    You can find the location of this folder via the shortcut (right click -> properties) you use to run Reddcoin Core.

  • The data folder. This folder holds the import files: your blockchain data AND your wallet.dat file.

    Use the steps described earlier to find this folder.

 

When Reddcoin Core (the wallet software) is started, it looks to your data folder, finds the blockchain data and your wallet.dat, and loads everything so the user can start using Reddcoin Core.

After reading your post, I think the issue is that Reddcoin Core looks into another data folder, so it does not load your blockchain data and wallet.dat, resulting in 6 years of syncing and 0 RDD.

 

There are a few things we could do to solve your issue. But, before I start suggesting, I want to know a few things, so I have the whole picture of the situation.

 

  • What is - according to Reddcoin Core - your data folder? To find this, you can use the steps you used earlier.

  • What is - according to you - your data folder? You previously copied some files over, it might be that folder. You also had files on your N: partition… If you don’t know the answer to this question, let me know.

 

Recovering from a wallet.dat file is really easy, you have to place it in the correct location. So, don’t worry about that…

Thanks for your quick response.

According to the Debug window, I am using v3.10.0.14-443248e-beta. I did not update it to v3.10.1 yet. I didn’t want to complicate matters.

The Debug lob file shows:

Using data directory C:\Eds Files\EInvestments\PB Infinity - crypto\Reddcoin\data

I had copied the folder in C: over to N: and that is where I thought the data directory would be since I started the Reddcoin core from the executable in N:

Can I just copy the backup wallet.dat into the data directory in C: and then start the core from C:?

How would I get it to use the directory in N:?

  • Ed

When you start Reddcoin Core for the first time, it asks you to select a folder to save your data (blockchain, wallet, etc).

After selecting a folder (or using the default), it will use that folder from that moment on.

To select a different folder, you need to use the -choosedatadir option/argument. When you start Reddcoin Core with that option/argument, it will ask you to select a data folder, which is what you want. In your case, you can select the folder on your N: drive.

Make sure your ‘correct’ wallet.dat file is in the folder that you select.

To start with -choosedatadir, do the same steps you did before for -rescan, but instead of using -rescan, use -choosedatadir.

So, it would look something like this:
C:\...\...\reddcoin-qt.exe" -choosedatadir

 

Let me know if this has worked out for you.

And after your wallet loads and works as expected, update to v3.10.1. :).

I did as you instructed. I put the wallet backup in the data directory in C: because when I tried to do it in N: it said it needed 20GB of space and that wasn’t available. I started the Reddcoin Core. It showed no RDD but it did show the recent transactions. It showed 6 years and 23 weeks behind. After a while it said 6 years and 21 weeks and then 6 years and 19 weeks. I thought that it just needed time. This morning, after synchronizing all night, it still says 6 years and 19 weeks.

  • Ed

Okay, I’ve lost the overview of were your files are…

I will just use the term “data folder”, with this I mean the folder that you selected to be used for your blockchain data and wallet.dat file.

 

Your issue is that the blockchain on your computer is not fully synced. Blockchain holds all the Reddcoin transactions, you need the complete blockchain to be able to do transactions. So, the blockchain needs to be fully synced before you can continue.

 

You can speed the blockchain syncing up by bootstrapping. With this method, you only need to sync the a few weeks instead of years.

The instructions are here: https://wiki.reddcoin.com/Bootstrap_the_Reddcoin_Blockchain.

Thank you. That did it. It came up 7 weeks behind and synchronized up to date.

  • Ed