Warning on my wallet

I’m currently syncing my wallet and get the following warning:

“Warning: Displayed transactions may not be correct. You may need to upgrade or other nodes may need to upgrade”

I’m using the latest wallet: v1.4.1.0-gecb564a-beta

Can anyone tell me if I should be worried?

aenor
If your still syncing, then that should be normal.
IF you are fully sync’d and you have that message, then need to investigate
How far into syncing are you (what block??)

2 Likes

It seems to be stuck on Feb 11th, no matter how long i have my wallet open for syncing.

I’m sure it used to sync faster than that before - perhaps there’s been loads of transactions and big blocks? Or something else is wrong?

aenor
What Block are you currently on??
If you check after 1 hour has the block count progressed?
My observation on syncing, is at times the process will pause, and then resume

It’s on 539045

Have been watching it for the last ten minutes and it hasn’t budged. Given that new blocks are being created every minute, at this rate I’m never going to catch up.

Restart the wallet and see if syncing continues.

Tried closing it down and restarting and it’s just stuck on that block.

But when I look at the task manager there’s a lot of CPU activity on the wallet - so it’s obviously churning it’s wheels, just not getting anywhere.

aenor
You mentioned at the start that you were currently syncing.
Was this a new installation?
or did you have your wallet closed for a while and it was catching up?

Personally i have had a few different issues syncing in the past, and usually always when i have done something stupid like turning power off PC before closing the wallet. (forced power off)
In everytime i have found a way to complete a sync…
Sometimes it just takes patience, and understanding the source of the problem.
As a note, if your wallet.dat is safe and you have backups… then your coins are going to be ok

[Just a couple of points to add]
After restarting, take a note of your Last block time/current block, and let it sync for about 30mins
Also, dbl check you have a connection to the network (Number of connections)

I tend to open the wallet about once a day. So I opened it and synced on Feb 10th with no problem. Opened it on Feb 12th and it got stuck and has been stuck ever since.

I had it open all last night to see if it would sync better if there was no other activity on the computer, and nada. No problems with connections, I usually have about 10 and sometimes as many as 24.

FWIW, the latest version of the wallet has been giving me a few problems - sometimes it just hangs there when trying to open it. The previous version used to just zip along.

aenor Hopefully you have a good couple of back up’s of your dat file…because it sounds like its time to do some re-install and resynch , a complete and utter pain…I know…but…its part of the game.

Reddshift aenor
That was going to be my suggestion.
Sometimes it needs a clean sweep.

There only 2 files you need to consider

  1. wallet.dat (the most important)
  2. reddcoin.conf (if it exists)
  3. Make sure you have extra copies of these as a backup

Shutdown Reddcoin-QT
delete the contents of C:\Users<username>\AppData\Roaming\Reddcoin
copy wallet.dat + reddcoin.conf (if needed) back to the above location
Start Reddcoin-QT

this will trigger a download of the blockchain from block zero

You can speed this process by including a bootstrap.dat file into the above location
You will need to download the latest bootstrap.dat.xz from Github and extract the contents into the above path

Reddcoin will detect this file first and import the blocks from disk (fast) before downloading the balance from the network (slower)
the bootstrap will be renamed after the import

Let me know if you need further details or clarification

Well I deleted and started downloading the blockchain again - and it’s now stuck on block 271844.

At least there are no warnings this time. Anyone know how I can unstick it without having to delete and download yet again?

aenor Try to close and reopen the wallet. If that doesn’t work, download the bootstrat file and follow the instructions.

https://www.reddcoin.com/how-to-re-sync-blockchain-3x-faster/

Well despite downloading bootstrap.dat and deleting the blockchain and downloading it yet again and again and again. it still gets stuck.

Looking at the debug log, all I’m getting is acres of the following:

2015-02-28 20:56:16 stored orphan tx f3d9596d35209a20c2f8ec066f88df39c8bd079fdf8e3422c51cd484bea4ccdb (mapsz 27)
2015-02-28 20:56:19 stored orphan tx 2deaa9f3f5315f9cf91f5e8a5e75c47e22acbb3847967eb38068f4b214f00467 (mapsz 28)
2015-02-28 20:56:22 stored orphan tx 492ee2ae18221c48fc2a9113b844a63c0ddb2e917a26d972f80c9617cad0b6c6 (mapsz 29)
2015-02-28 20:56:25 stored orphan tx 88d7d9b8972568c0cdec14321a08cf8fa3fe67fc29ee359534c39dc4872c0f91 (mapsz 30)
2015-02-28 20:56:34 stored orphan tx e7d4a4d65f233758b6e8c2f8004bf70fbc25dd0a13026079f9010fe7f162554d (mapsz 31)
2015-02-28 20:56:38 stored orphan tx 06dfb62d2065dae654a73b12c02a5916566e8c5a9c427339de6726c1dae2fbe5 (mapsz 32)
2015-02-28 20:56:50 stored orphan tx 73b6f934eee134cacbaefed9c6a7a29fca601517b83c840e924b420bbb52c661 (mapsz 33)
2015-02-28 20:57:12 ERROR: CheckProofOfStake() : block not indexed
2015-02-28 20:57:12 WARNING: AcceptBlock(): check proof-of-stake failed for block ff12782b2981361c3485c88094e0a5011666e69872e4df4a66d727c2e98e0125
2015-02-28 20:57:12 ERROR: ProcessBlock() : AcceptBlock FAILED
2015-02-28 20:57:14 stored orphan tx 406a2cf70500bd59a0af73214b174c343b7f9667142cc6e4c16550827939ecba (mapsz 34)

Over and over - it’s always the same tx codes - as though it was caught in a loop of some sort.

Very fed up of this now. FWIW the problems only started with the latest version of the wallet - previous versions had no problems.

aenor Did you unlock your wallet for staking before the blockchain was full downloaded??

Nope did not unlock. Was trying to download the blockchain first.

I think there’s a problem with compatibility - because in the debug log there were error messages about disconnecting with nodes that were the previous version too.

I think I might leave the whole thing till the next version of the wallet comes out, which hopefully fixes the problem.

Can you post the contents of your reddcoin.conf file?

aenor Please check your reddcoin.conf file and make sure you DO NOT have *txindex=0" in it. txindex must be turned on and it is by default.

1 Like

Where do I find the reddcoin.conf file?

I’m using Windows and there is no such file in AppData/Roaming/Reddcoin Am I looking in the wrong place?

Am also getting the following messages in the debug log when I try to sync:

2015-03-05 01:01:38 ERROR: CTxMemPool::accept() : tx with old pre-PoSV version
2015-03-05 01:01:38 ERROR: CTxMemPool::accept() : tx with old pre-PoSV version
2015-03-05 01:01:38 ERROR: CTxMemPool::accept() : tx with old pre-PoSV version
2015-03-05 01:01:38 ERROR: CTxMemPool::accept() : tx with old pre-PoSV version

2015-03-05 01:01:53 CSyncCheckpoint::CheckSignature() : successfully verified signature
2015-03-05 01:01:53 ProcessSyncCheckpoint: pending for sync-checkpoint 41f9c4816938a15c6a8a9aa13d70f1b82d20de9f2dbb892d9a39c99196106521
2015-03-05 01:01:53 Misbehaving: 24.42.248.127:45444 (0 -> 1)
2015-03-05 01:01:53 ProcessMessage(checkpoint, 110 bytes) FAILED

2015-03-05 01:02:04 connected 83.93.0.198:45444
2015-03-05 01:02:04 send version message: version 80000, blocks=276815, us=92.18.14.91:45444, them=83.93.0.198:45444, peer=83.93.0.198:45444
2015-03-05 01:02:04 Added time data, samples 7, offset +13 (+0 minutes)
2015-03-05 01:02:04 nTimeOffset = +9 (+0 minutes)
2015-03-05 01:02:04 Moving 83.93.0.198:45444 to tried

2015-03-05 01:03:30 accepted connection 192.241.197.116:60825
2015-03-05 01:03:30 partner 192.241.197.116:60825 using obsolete version 70002; disconnecting
2015-03-05 01:03:30 ProcessMessage(version, 100 bytes) FAILED
2015-03-05 01:03:30 disconnecting node 192.241.197.116:60825

It seems to me that it’s trying to connect to various nodes and then rejecting them either because they are an old version or they are “misbehaving”. Are there a lot of old versions out there - for example do exchanges like Cryptsy, which stake, know about the new wallet?

aenor
Hi Aenor

could you provide more of your debug log?
Send me a PM
i just did a quick scan of my log as comparison and i dont see any message relating to pre-posv