Black Square in Privkey

. I had to swap my wallet to a bigger SD card bc the blockchain has become bigger. Everything went smooth until I wanted to restore the wallet. Typed importwallet /home/pi/Desktop/WalletBackup.dat and it indeed seemed to upload my walletbackup file from the desktop just fine. Alas, nothing happened for days, still everything on zero despite the wallet being fully synchronized and the backup uploaded. Then I thought no problem, I restore my wallet via the privkey. But the privkey has a black square among the numbers and letters, and I don’t know how to type that in. Have you ever encountered such problem? Contacted the RDD team, alas no response.

Hi there.

Some questions, to make sure everything is clear:

  • You’re using Reddcoin Core on a Raspberry Pi, correct?

  • How did you do the restoring/importing the wallet? Where did you “Typed importwallet /home/pi/Desktop/WalletBackup.dat”?

  • To import a private key (privkey), you need to extract it first. So, I assume you extracted the private keys beforehand, and tried to import them?

  • When restoring the wallet, to which location did you restore the wallet? And what was the file name of the file you restored on that location?


  • Are you using VNC to connect to your Raspberry Pi?
  • Which version of Reddcoin Core are you using?


A lot of questions, please answer as much as possible, post as much information as possible.

Steps for restoring a backup of wallet.dat:

  • Make sure Reddcoin Core is not running. If it is running, exit/close Reddcoin Core.

  • Go to your “data folder”. In this folder, all the blockchain files are saved, and also your wallet file (wallet.dat).

    • This folder is located in your ‘Home’ directory. It is a hidden folder named “.reddcoin” (with a dot in front).
      Open your home folder in the file explorer, and look in the ‘View’ menu to see if you can see ‘hidden files’.
    • Open the “.reddcoin” folder!
  • In the “.reddcoin” folder, there is already a file named “wallet.dat”. Rename this file, for example to “old_wallet.dat”.

  • Now, copy your backup wallet.dat file to the data folder.

    • The data folder now should have a old_wallet.dat file and wallet.dat file.
  • Run Reddcoin Core. The wallet you restored should be loaded.


Let me know if you have questions or need any help.

1 Like

If you have a password on your wallet, unlock the wallet first before importing private keys.

  • Settings -> Unlock wallet -> leave ‘For staking only’ unchecked (only to import; when staking, do check it).

You can import a private key via:

  • Help -> Debug window -> Console => enter this:
    importprivkey <reddcoinprivkey>

For example:
importprivkey vrandomrandomsdfjsidjfji2232


You can add a label to your address, for example, to give label ‘MainAddress’:
importprivkey vrandomrandomsdfjsidjfji2232 MainAddress

  1. yes, on a raspberry pi, in fact the staking box from pi sales.
  2. they sold it with a 16 GB SD a year ago, then my box stopped staking this summer and it turned out there was no space left on the SD, fun fact: turns out the staking box is now being sold w a 32 GB SD bc the blockchain has become too big. I bought a 32 GB SD card from them on which everything was perinstalled, thus changed the SD cards in my stake box and have the latest version of the wallet on it, synced and everything.
  3. Then put the backup file on the pi desktop as well. Went to the debug window in the wallet. That’s where I typed the command importwallet etc. The upload bar showed, went up to 100 % and all seemed fine.
  4. I ve extracted the privkey from my old wallet with the command dumpprivkey and my receiving address in brackets. That, fortunately, I actually did before I went away for the summer and the wallet went dead / stopped staking on the old SD card. The privkey was displayed, all fine. It has 52 characters including that black square that I didn’t worry about then.
  5. I transferred the backup file of my wallet from my usb to the desktop of the pi after I had put the new SD card into the pi. I only transferred the backup file when everything seemed to be working nicely already, that is surface of the pi looked slick, VNC was enabled.
  6. I executed the wallet protocol on the pi, synced it, when it was synced, I went to the debug window (console) to type in the “importwallet command”


I can’t see much on the screenshot, can’t say anything useful…

By the way: Your current wallet has 0 RDD, correct?

That’s correct 0 RDD, no transaction nothing there. The screenshot needs explanation: that’s the “black square” in the privkey.


You extracted the private key before the summer, right? That private key has no black squares, right?

Did you do these steps to import?

  • Unlock wallet and use importprivkey. Explained in a post above.
  • It can take a while to import a private key, so if the wallet seems frozen, leave it as is, it’s busy importing…

No, that’s unfortunately the privkey from b4 the summer that already had the black square in it, only I didn’t think of it as weird then. Today, I ordered a new / plain 32 GB SD card, was thinking that I could put an image of the old 16 GB SD card on it, then plug that one into the raspberry and see if the old wallet (that was also already running on the latest RDD wallet update) opens on it like it used to, and if I could retrieve the privkey from there one more time. Side note: after the 16 GB SD card wallet had stopped staking at the end of summer, everything still seemed fine except it was not staking since there was no space left, when I looked at the pi again a day or two later (wanting to have another after summer backup and recheck the privkey again b4 putting the new SD from pi sales in) via VNC and then also directly via HDMI monitor connection the pi was black, so another backup or just checking the privkey one more time was not possible.

This is what the pi screen has been looking like at the moment


I myself never had the issue of a black square. Always had a letter/number…
I assume something went wrong when exporting or copy/pasting the private key.

  • Do you still have the 16 GB card (with your old data)?
  • Do you have a backup of the wallet? In this case, the backup is a “.dat” file (like: ‘wallet.dat’).
    A backup can be made in Reddcoin Core, using the ‘File’ (menu) -> ‘Backup wallet’ option.

Have you ever heard of TeamViewer? It’s a program that can be used for remote control, so somebody else can help you via the internet.

Would you be willing to let me help you using TeamViewer? I know it is crypto, so I know I understand if you do not want this.

What I would do:

  • I see a WalletBackup.dat file on your Desktop in the screenshot.
  • I will place this file in the correct folder.
  • The steps I will take are detailed here.

Yes, I still have the 16 GB, which is now black when put back in the pi. My guess is that it ran out of space. That’s why I was thinking about making an image of it on my PC, then transfer it to a plain 32 GB SD, insert that one and see if — hopefully —- the old wallet opens again and I could dump the privkey again.
And yes, backup files .dat from September 19, April and June 20.
Re the black square - yes rmmphh I thought it was a display error, first I mistook it for an m but when u zoom into it, see above, it is a black square, right? Thank you! I ll keep u posted

Okay, you have a backup file. We can use that to restore the wallet! :).

You can try doing that by yourself, using the instructions I posted earlier. Or I can help via TeamViewer.

1 Like

And? Any updates? Let me know if you need help.

Hey there, no update as of yet except I ve managed to make an image of the old SD card on my PC. Took about 5 attempts. Will transfer the image to a new, bigger SD card, put it in my PI and see if I can get the old wallet running like b4 and then hopefully retrieve the privkey one more time! I ll keep u posted! Thank you for hanging in there with me.


But did you try to use the backup file you have uploaded to your Desktop (the WalletBackup.dat file)?

I have made a video for you:


  • Make sure Reddcoin Core is not running. If it is, exit/close Reddcoin Core.
  • Transfer the backup of your wallet.dat to your Raspberry Pi via VNC.
    You already did this.
  • The file is now on the Desktop of your Pi.
  • Rename the file, to wallet.dat (all in lower case).
  • Open the file explorer. By default, it opens on your 'home' folder.
    Your home folder has folders like: Desktop, Documents, Downloads etc.
  • Now, make hidden folders visible. You can do this via ‘View’ -> ‘Show Hidden’ (or by using CTRL+H).
  • You will see some extra folders/files appear. One of those folders is '.reddcoin' (with a dot (.) in front).
  • Open the .reddcoin folder. This folder is the ‘data folder of Reddcoin Core’.
  • In the .reddcoin folder, you will see a wallet.dat file. Rename this file to something else (for example: old_wallet.dat).
  • Now, copy the wallet.dat on your Desktop (your backup) to the .reddcoin folder.
  • Start Reddcoin Core.
  • Check if your balance is restored/as expected.

And, how did it go? Did you see the video and instructions above?

@Lilly_Sanders, can you confirm if your issue has been solved?