QT Wallet Crash / Sync /Lost coins issue?


Ive had an interesting issue that Im hoping someone can shed some light on…

Im running the QT wallet, had 34M RDD in it…
Computer crashed, rebooted Wallet was out of sync and then wouldnt sync it was just stuck on the same block, most likely block lock file issue…
I then cleared the block files, re loaded and re synced… BUT now that its finished its only showing 1M RDD in total…

When it crashed it was staking 32M RDD at the time…

When I use the Block / Address explorer it shows on my 4 addresses that the 34M is still against them, but the Wallet doesnt show that…

It also doesnt say that the 33M is staking.

Will the system just catch up once it stakes again for the first time? Or have I lost the coins?
Wallet version v1.4.0.0-g353b9a5-beta

Any suggestions would be appreciated.


omg that’s unbelievable, 34m to 33m? 1.000.000 difference! .-.

lottery248 It went from 34M to 1M so its a difference of 33M thats why im concerned about it…

oh, mah boi,

o m g how is it possible?

Try reinstalling the wallet(use the wallet.dat), and resyncing. If the explorer is showing your coins, then it should be the client which is corrupted.

1 Like

lottery248 lol thats what Im trying to find out… Is it possible that the wallet.dat file can be corrupted?

oz i think that next time if you wanna prevent this happening, you should always back up your wallet.

OzVirtualPaul That is really bad. you maybe lost some change addresses if your backup wasn’t up to date. https://wiki.reddcoin.com/index.php?title=Change_Addresses

lottery248 I have several backups of my wallet.dat

you should keep your files away from your computer, use cloud storage, so the stuff will not be affected.

lottery248 yeah I have copies on Dropbox… Ill try fully uninstalling and re installing…

OzVirtualPaul Hope for the best!

Joawsch Thanks, installing now and with 41 weeks behind (to sync) I only have 17,361.19RDD at this point… interesting

As the sync progresses through the blockchain, for each of your addresses the known coins known at that block will be added.
After it is fully snyc’d all of your known coins should have been added back to the client.


OzVirtualPaul update?

Just an update (hopefully to help others)

Well tried recovering many ways, also tried using the -rescan and -salvagewallet commands (and a few others), but that didnt help.

Every re sync only got me back to 1M and the 33M missing, which was the Staked amount at the time of the crash…

I then decided to play with the Electrum wallet, downloaded it, to the first option of recover a wallet, went to the next screen but realised I didnt have any of my address information, closed it, loaded the QT back up and to my surprise the amount was back to 34M!!!

It also continued to sync pass the block it had been stuck on for a week.

I can only assume the electrum program did something to correct what ever was not right.

Now I did lose about 4 days of staked transactions (my history before had staked up to the 25th but my history went back to the latest transaction only being the 21st)… So I have lost maybe 10K but I can live with that…

But I started staking again and within 30 mins I gained 4k back again…

Now i do have concerns about the safety of staking, I would never had through that this could happen, so I dont know if I had been very unlucky with timing of the crash for this to happen like this… So I wont be shutting my PC down mid stake thats for sure…

Also I thought backing up the wallet.dat was enough but clearly not… My new policy will be to backup everything weekly after QT is shut down…

Recovering 33M RDD is a great new years day gift thats for sure :slight_smile:

P.S I have copies of logs if the devs are interested

1 Like

OzVirtualPaul My question is: do you change or tweek any options on coin control features?

Staking by default does not allow you 33M… if I’m not wrong… that was one of the things that was solved in the second revision of the wallets by the DevTeam after PoSV because too many people were locked out from staking. So this option wouldn’t occur to the end user.

Although the advanced one would have this freedom to use the program as he see fit.

Could you elaborate a bit more on these details, please?

Oliver No none at all, trying to recover was the first time I ever even tried any of the parameters…

That was also the first time I had seen it stake so much before as well, like now its only staking 2M

The crash was caused by another program on my machine…

1 Like