[Solved] Reddcoin 3.10.3 core crashes: !"cannot load block from disk"

My Reddcoin wallet worked fine for years, running 24x7 to keep staking. Now on v3.10.3.0-00eedb8-beta (64-bit). But last weeks it keeps crashing:

Assertion failed!
File: main.cpp, Line 3837
Expression: !“cannot load block from disk”

I already rebuilt with the bootstrap files, but now always a few hours after starting up the app crashes with this error message.

Any clues how to fix this?

First time I’m seeing that error. Reading the error and searching some on the internet, I think the issue might be related to your hard drive.

I would recommend to check the health of your drive.

You can use CrystalDiskInfo, for example.
A portable version (works without installing): https://portableapps.com/apps/utilities/crystaldiskinfo_portable.

Can you run that software and post a screenshot of the results?

Thank you, here the screenshot. Looks good i guess. Also my ‘Hard Disk Sentinel Pro’ utility does not signal any errors.

Is your blockchain data saved on D: or E:?

By default, it’s stored on C:.

Can you also post a screenshot of C:?

Program and data all on D:


You already have deleted existing blockchain data and bootstrapped. That’s what I would do as well. That doesn’t seem to have fixed the issue…

In your case, I would try the following myself:

  • Exit/close Reddcoin Core, make sure it’s not running.
  • Copy the current Reddcoin data directory to another partition on another drive. In your case, I would go for F: or G:.
  • Start Reddcoin Core with -choosedatadir, and use the new location (on F: or G:).

Then, I would monitor if Reddcoin Core still gives an error.
If there is no error, the disk would seem to be the issue.
If it does give an erorr, I will ask you about how you have done the bootstrapping, to make sure you haven’t missed anything.

Ok, will try. Reddcoin data and Redcoin core are in 1 directory on D. Can I copy the whole folder to another drive then? Do I still have to use -choosdatadir?

Or should I only move the /blocks and /chainstate folders to another disk and restart with -choosedatadir?

I can give you the exact instructions, but I need to know if we talk about the same thing.

  • Reddcoin installation/program directory:
    Contains the wallet software - Reddcoin Core.

  • Reddcoin data directory:
    Contains the blockchain data and your wallet file, and other necessary files.


Can you post the location of these 2 directories? And a screenshot of the content (so I can see/verify it’s the correct folder).


  • Don’t move anything, but copy.
  • You only need to copy your Reddcoin data directory (contains your blockchain folders).
  • You need to start with -choosedatadir to make sure Reddcoin Core uses the new location.

I will tell you exactly how to the steps, but first I need to know the locations.

All is in 1 directory on D:

Okay, current location is: D:\Reddcoin.

  • Copy the Reddcoin folder on D: to F:.

  • So, the new location is: F:\Reddcoin.

  • Start Reddcoin Core with the -choosedatadit parameter/argument.

    • Press Windows key + R.
      The ‘Run’ window should open.
      In Run, enter this (copy/paste):
      "F:\Reddcoin\reddcoin-qt.exe" -choosedatadir
  • Reddcoin Core will start (from the new location). It will ask you for the data directory.
    → Select F:\Reddcoin as your data directory.


Check if this solves your issue…

I chose H, a healthy SSD drive…:slight_smile:

Done, up and running now, will let you know, thanks a lot!

And? Had any issues since running Reddcoin Core on H:?

Hi! All running fine now on H! I guess you were right about the disk. Very strange that 2 disk-checkers do not notice this :-(. Thanks for your help!.

I would recommend you to backup the data on the drive with possible issues.

Glad Reddcoin Core works without issues on H:.

Well, one month further. I have had several of the same crashes now on drive H:

Assertion failed!
Program: H:\Reddcoin\reddcoin-qt.exe
File: main.cpp, Line 3837
Expression: !“cannot load block from disk”

From debug.log:

2021-03-12 07:00:04 Unable to open file H:\Reddcoin\blocks\blk00025.dat
2021-03-12 07:00:04 ERROR: ReadBlockFromDisk : OpenBlockFile failed
2021-03-12 07:18:33 socket sending timeout: 1201s

Not nice, cannot stake now :-(.

When you stake, Reddcoin Core takes into account the last time you got a stake reward, and the amount of time the coins are in your wallet.

So, if you don’t stake for 10 days, those 10 days will still be included in the next stake reward.

Is there a possibility for you to store everything related to Reddcoin Core on the C: drive?
This included the blockchain data that is currently stored on the other drive.

I have never had this error myself, and also not seen it come back like this… The only reason I can think of is that one of your disks is dying and causing the issue, but that also doesn’t seem to be the case, as the SMART info looks OK…

Ok, let me get this straight: simply copy everything from current F: to C: with this procedure?

  • Copy the Reddcoin folder on F: to C: .
  • So, the new location is: C:\reddcoin .
  • Start Reddcoin Core with the -choosedatadit parameter/argument.
    • Press Windows key + R .
      The ‘Run’ window should open.
      In Run, enter this (copy/paste):
      "C:\reddcoin\reddcoin-qt.exe" -choosedatadir
  • Reddcoin Core will start (from the new location). It will ask you for the data directory.
    → Select C:\reddcoin as your data directory.

I can try, but why? I already did that last time, from D: to F:. You think I am maybe very unlucky with 2 faulty drives (D and F)?

(Just saw your message here… I am now mostly busy with the Reddcoin Helpdesk, so I don’t read here often anymore.)

That would be weird… I don’t expect that to be the issue…
It is possible that something is still wrong with your Reddcoin Core.

Let me know if you are OK with this proposal:

  • Using TeamViewer (program), you can share your screen with me.
  • I can then check your Reddcoin Core settings, check your debug.log etc, to see if everything is OK.
  • If needed, I can delete existing blockchain data and redownload it and do all the necessary steps for you. This might/could fix the issue.

If you agree with that, let me know. We can setup a date and time, so I can have a look.

If you don’t agree (for whatever reason), would you be willing to email me your debug.log?