[Solved] The transaction was rejected!

Hi,

I was asked to post here by Yavuz Salim and to link back to the issue I posted on the Reddcoin Reddit sub here: https://www.reddit.com/r/reddCoin/comments/lhnz0n/the_transaction_was_rejected/

To save you a click, my issue is that I restored my wallet from backup. Not looked at it for 2+ years. Fired up the wallet, imported the wallet.dat using my wallet password. Waited for the sync to catch up and then tried to send them to an exchange. I get the error:

The transaction was rejected! This might happen if some of the coins in your wallet were already spent, such as if you used a copy of wallet.dat and coins were spent in the copy but not marked as spent here.

While this wallet is clearly a backup as I imagine most people’s are at some stage, it synced fine and has all my transactions in it so I’m confused as to why I’m seeing this error message. I’m trying to transfer far less than the charge assigned to the transaction.

If anyone has any pointers on what I need to do to rectify this situation, I’d appreciate it.

Hi there.

 

 

Let me know when you have done these steps.

Hi,

Thanks for taking the time to help with this. I was already running the latest wallet so I’ve backed up as requested and I have downloaded the Nov 26 blockchain.

Awaiting your instructions!

Thanks.

  • Press the following keys: Windows key + R.
    This opens the ‘Run’ window.
    In that Window, enter:
    %AppData%

  • A new window opens, with folders. Search and open the Reddcoin folder.
    This folder is your Reddcoin data folder.

  • Delete the following folders:

    • blocks
    • chainstate
  • Delete the following file:

    • peers.dat
  • Leave this window open.

 

  • You have previously downloaded the blockchain-Nov-26-2020.zip file.
    Extract the zip file:

    • To unzip all the contents of the zip file, press and right-click the file, select Extract All, and then follow the instructions (next, next, next).
  • After the file is extracted, you will see two folders: blocks and chainstate.

  • Move (cut/paste) these 2 folders to the other window that you left open (where you previously deleted folders and a file).

  • → After everything is working again, you can delete the large blockchain-Nov-26-2020.zip file.

 

  • Open Reddcoin Core. It will start syncing the rest of the blockchain (last 10 weeks).
    Don’t touch Reddcoin Core, let it sync.

 

In your case, I would recommend waiting for a stake reward before making a transaction. You should receive a stake reward fairly quickly, as you have not used your wallet for 2+ years. After getting a stake reward, you can make the transaction. But again, you don’t need to wait, you can make the transaction whenever you want.

 

You now can make the transaction again.
When sending, do this (in the Send window):

  • At the bottom:

    • Click on ‘Choose…’ at the bottom.
    • Select ‘Custom’.
    • Select ‘total at least’.
    • Set value of ‘total at least’: 1 RDD.
    • Uncheck ‘Send as zero-fee transaction’.
  • At the top:

    • Enter the receiving address
    • Enter the amount, minus 0.1 RDD.
      • So, if you want to send 123.45 RDD, send 123.35 RDD.
      • 5 RDD → 4.9 RDD.

 

Let me know how it goes.

After a minute or so, the transaction should get confirmations.
The transaction should appear on the blockchain explorer; http://live.reddcoin.com/.
Go to that website, and enter the transaction ID.
If you can find the transaction, the transaction is successful.

 

Let me know how it goes.
If you have any questions, do ask. :).

Perfect, that’s worked, thanks!

Only diff is the Reddcoin wallet data folder was in C:\reddcoin.

All other steps worked perfectly.

Thanks again.

When you run Reddcoin Core for the first time, the software asks you where to put the data files. In my instructions, I have used the default folder. It seems that you had selected a custom folder (C:\Reddcoin).

 

Glad your issue is solved!

I had the same issue as SimonJ. I went through all of the steps you outlined, using a fresh install of the core wallet and a restored backup of my wallet, which has not sent or received anything in over three years.

I used the bootstrap file to catch up after deleting the files you outlined in the solution, but I am still getting the same ‘transaction rejected’ message. Are there any other pitfalls I should look out for? My 108,000 RDD are in my wallet and can’t get out. Thanks in advance.

@atbaxter

Can you please create a new topic, and post as many details as possible about your issue?

Turns out that won’t be necessary. I used an even older wallet backup and my transaction worked just fine.

Thanks for your responses!

Hi,
I’m having the same problem.
Allready running the latest wallet.
Can you re-upload the blockchain zip so I can try the steps you have given.