Transaction Still Unconfirmed Need Assistance Please

Is there anyway to cancel a transaction?
I have sent and received RDD to and from my account before, been staking for a long time but took a long absence due to some travel and focus on other things for a while.
I was in a rush and intiated a few crypto transactions from various wallets for various coins.
I didn;t realize that my RDD Wallte had not yet finished synchronizing and tried to send my balance to my Bittrex account.
This was over a month ago and I am now giving up on trying to restrate fresh.
I have allowed the wallet to sync.
I am running Reddcoin Core version v3.10.3.0-00eedb8-beta (64-bit) on my Mac.

I didn’t want to make any changes to anything and further complicate things.
I figured my best bet was to seek advice from the community before I make things worse.
I have provided the information on the transaction below.

Status: 0/unconfirmed
Date: 1/2/21 20:26
Transaction ID: b2df8dc0c6dee981242081ca800789ca54184bb3c298362323650c6109b41a80-000

Not sure if a few was not included and that is causing the problem.
But is there a way to cancel this so that the balance is placed back on the ledger appropriately?
Then I can try my transaction again as everything is prepared and ready to go.

Any help would be greatly appreciated.
Thanks in advance.

All right, wise decision to seek help before making things worse. :P.

I will get back to you later today, in the mean time, please download this large (4 GB) file: https://download.reddcoin.com/bin/bootstrap/blockchain-Nov-26-2020.zip. You will need it later, so better to already have it downloaded.

Don’t worry, your RDDs are safe. We’ll recover them together.

1 Like

Do these steps after yourr file is downloaded…

I assume you have put the Reddcoin-Qt application in your Applications folder.
If this is not the case, let me know.

The first step is to remove the unconfirmed transaction from your wallet.
The amount will be restored to your balance.

  • Open Reddcoin Core and make a backup.

    • File (menu) → Backup wallet.
    • Do not skip this step.
  • After making a backup, exit/close Reddcoin Core.

  • Open the Terminal app.

  • Enter these commands in Terminal:

    • cd /Applications
    • Reddcoin-Qt.app/Contents/MacOS/Reddcoin-Qt --zapwallettxes=1
  • Reddcoin Core will start, let it load. It can take a while.

  • After Reddcoin Core is fully loaded, check your Transactions list and your balance. The transaction should have been removed, and the RDDs are placed back in your balance.

Let me know how it goes. If all went OK, we will continue with the steps next.

1 Like

I just completed the steps and it worked like a charm. Love that it even cleaned up all the other transactions where I didn’t get the staking. Nice and clean. If you send your address, I will send a tip. Thanks for the help, it was greatly appreciated.

Glad to read! :).

You can send your tip to: RbhPteN2GXV9Ne45agjYYAYKYtPWkizrLU

Thank you, I appreciate it!

1 Like

Just sent it. So you should see it soon.

Yes, I have received it!

Thanks a lot, I appreciate it!

Edit: read post below.

1 Like

Hi,

Checking the address on the blockchain, I see that I have received a transaction 50 minutes ago. Your transaction was 1 hours or so earlier, so if I understand the situation correctly, I have received RDD from someone else, and not you.

Can you check the transaction in Reddcoin Core? I think it’s not getting confirmed and has an unconfirmed status. Is this correct?

It might be an issue of sending with a transaction fee that’s too low.

As I look at it, I don’t see any reversal.

Status: 162 confirmations, broadcast through 8 nodes
Date: 2/8/21 15:29
To: RDD Community Support yavuz_selim RbhPteN2GXV9Ne45agjYYAYKYtPWkizrLU
Transaction fee: -0.00085217 RDD
Transaction ID: 99d5d51e8bc2ed29496bc3f7fe6cf36351ab0ff47bf0fc79885bd280749f8557-000

To help ensure it would go through I increased the fee so I don’t think it would be that. I slid it to the right to help reduce time.

Shutdown and reopened. Looked at the Transactions and still have a green check by the transaction. And the details above are still listed.

You can find any Reddcoin transaction on the Reddcoin blockchain explorer on https://live.reddcoin.com/.
You can use the blockchain explorer to confirm that a transaction is actually on the blockchain.

In this case, when you search for the transaction 99d5d51e8bc2ed29496bc3f7fe6cf36351ab0ff47bf0fc79885bd280749f8557 on the blockchain, you will see that “no matching records are found”.

This means while you see ‘162 confirmations’, that the transaction is actually not confirmed.

So, there is a small issue with the blockchain on your machine. Let’s fix that issue.
Please follow the instructions in the post below.

Let’s make a backup again, just in case.

  • Open Reddcoin Core and make a backup.

    • File (menu) → Backup wallet.
    • Do not skip this step.
  • After making a backup, exit/close Reddcoin Core.

 

Now, let’s delete existing blockchain data.

  • Open the Finder app, and, in the top menu, select Go > Go to Folder.
    Enter this:
    ~/Library/Application Support/Reddcoin
     
    The folder you see, is your Reddcoin data folder.

  • Delete the following folders:

    • blocks
    • chainstate
  • Delete the following files:

    • peers.dat

 

  • You previously downloaded this file: https://download.reddcoin.com/bin/bootstrap/blockchain-Nov-26-2020.zip. Do you still have it? If not, please download it again.

  • Find the downloaded file and move it to your Reddcoin data folder (the folder where you previously deleted files). The blockchain-Nov-26-2020.zip should now be in the same folder as a file named wallet.dat.

  • Double click the blockchain-Nov-26-2020.zip file. It will unpack/extract/unzip. After this step is completed, you will see 2 new folders: blocks and chainstate.

  • You can delete the blockchain-Nov-26-2020.zip file.

 

If you can’t find the blockchain-Nov-26-2020.zip after it’s downlaoded:

  • I don’t know by heart how macOS handles the download of .zip file. If the file is unpacked/extracted/unzipped immediately after the download finishes, I assume you’ll find a folder named blockchain-Nov-26-2020 with the 2 previously mentioned blocks and chainstate in it. If this is the case, you can just move (cut/paste) the 2 folders into the Reddcoin folder.

 

Now, start Reddcoin Core. It still needs to sync 10 weeks worth of blockchain data. Leave Reddcoin Core open, do not make any new transaction.

  • You can follow the progress via Help -> Debug window. ‘Last block time’ should increase.

  • Also, to make sure the sync finishes quickly, do the following:

    • Go to: Help -> Debug window -> Peers.
    • Make the window and columns wider if needed, you are interested in the ‘User Agent’ (2nd) column.
      • User agent Reddcoin Core:3 is OK.
      • User agent Reddcoin Core:2 is not OK. If you see on of these, right click on it and select ‘ban node for 1 year’.

 

After the blockchain is fully synced, the transaction you made earlier to me, should also be removed (restored to your balance). You now can create a new transaction.

When making a new transaction, do this (in the Send window) to ensure a speedy transaction:

  • Enter the receiving address and the amount.
  • Click on ‘Choose…’ at the bottom.
  • Select ‘Custom’.
  • Select ‘total at least’.
  • Set value of ‘total at least’: 1 RDD.
  • Uncheck ‘Send as zero-fee transaction’.
  • Make the transaction.

(When I do this, the transaction fee ends up being 0.1 RDD.)
This will make sure your transaction fee is higher than 0.001 RDD and thus your transaction will be confirmed quickly.

 

Let me know how it went.

If you need help with the steps above, let me know.

This transaction is not in the blockchain. So, something seems to be off.

Have you seen my posts above?